Прошивка OpenWRT на Netgear WRN3500L v.1. Установка и настройка

Страница на сайте проекта по данному роутеру: https://openwrt.org/toh/netgear/wnr3500l

Прошивка скачать OpenWRT 19.07.3 для Netgear WRN3500L v.1. Данный chk файл ставится через стандартный веб интерфейс в качестве обновления прошивки.

Примечание — роутер WRN3500L v.2 — окирпичивается, — на такой роутер не ставь!

Далее настройка через Веб-интерфейс(192.168.1.1) или SSH:

Установка пароля для пользователя root

Все устройства, кроме wlan и lan я удалил, т.к. по-умолчанию у меня не заработал Инет. После экспериментов с чисткой интерфейсов пропадал доступ по сети к роутеру.

Как раскирпичить

Чтобы оживить роутер восстанавливал сеть по UART USB.

Распиновка UART кабеля для WNR3500L:

Подключаемся  при помощи Putty на COM порт, включаем роутер видим загрузку его в режиме онлайн. Жмем Enter — входим в режим программирования, и пишем свои конфиги.

[свернуть]

Переходим в «Network» — «Interfaces»
В настройках будет три интерфейса: LAN, WAN, WAN6. Удаляем WAN и WAN6, остаётся один LAN.

Переходим в «Network» — «Switch»

Создаём два vlan, один, возможно, уже присутствует, второй добавим с помощью кнопки «Add«.
vlan 1 будет смотреть tagget на CPU (eth0) и untagget на порт, который будет нашим новым WAN. В примере это WAN и есть(т.е. можно любой порт сделать WAN’ом).
vlan 2 будет смотреть tagget на CPU (eth0) и untagget на все остальные порты.
Нажимаем «Save» для сохранения.

Теперь пинг на шлюз провайдера или Интернет пошел с самого маршрутизатора. Для раздачи Интернета в сеть теперь нужно настроить Firewall. Он у меня тоже не запускался, после чистки, поэтому переустановил firewall и iptables.

Пример скрипта удаления пакетов ip6 в OpenWRT

#/bin/sh
echo net.ipv6.conf.all.disable_ipv6=1 >> /etc/sysctl.conf opkg remove ip6tables
opkg remove kmod-ip6tables
opkg remove odhcp6c
opkg remove 6relayd
opkg remove kmod-nf-ipt6 —force-removal-of-dependent-packages
opkg remove kmod-nf-conntrack6 —force-removal-of-dependent-packages
opkg remove kmod-ipv6 —force-removal-of-dependent-packages
reboot

[свернуть]

При установке Firewall, ругнулся, что WAN зоне не сопоставлено устройство WAN.

Идем в «Network»«Interfaces», сопоставим wan зоне файревола интерфейс WAN

Идем в «Network»«Firewall», прописываем пересылку из внутренней стеи наружу

После этого пинг из локальной сети пошел наружу.

 

Пример  настройки wan-интерфейса.

Статический адрес (больше примеров можно посмотреть в официальной документации Network configuration). Тут всё как в обычном Linux, с помощью консольного текстового редактора vi вносим изменения в файл конфигурации /etc/config/network

root@OpenWrt:~# vi /etc/config/network
config interface 'wan'
	option ifname 'eth1'
	option proto 'static'
	option ipaddr 'xxx.xxx.xxx.xxx'
	option netmask 'xxx.xxx.xxx.xxx'
	option gateway 'xxx.xxx.xxx.xxx'
	option dns 'xxx.xxx.xxx.xxx'

После того как внесли изменения и сохранили файл, осталось перезапустить сеть для применения изменений:

root@OpenWrt:~# /etc/init.d/network reload

Конфиги

В итоге пример рабочей конфигурации сети на WNR3500L такой:

vi /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option delegate '0'
        list ipaddr '172.16.63.1/24'
        option ifname 'eth0.2'
        option gateway '192.168.1.254'

config switch
        option name 'switch0'
        option reset '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 8t'

config switch_vlan
        option device 'switch0'
        option ports '1 2 3 4 8t'
        option vlan '2'

config interface 'WAN'
        option proto 'dhcp'
        option ifname 'eth0.1'
        option type 'bridge'
        option delegate '0'

 

Пример всей конфигурации файрвола /etc/config/firewall:

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 WAN'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

 

 

 

Использованная литература:

https://radiolis.pp.ua/kompyutery-wifi/48-ustanovka-openwrt-i-perenaznachenie-wan-porta

 

Автор: Электроник

Системный администратор широкого профиля. От ИТ до Маркетинга. Мастер на все руки.

Добавить комментарий

Ваш адрес email не будет опубликован.